Billing Linux cPanel Windows Control Panel Client Voip ms sql webadmin ms sql backup mysql webadmin Server Status

Main Menu

ASPnix Knowledgebase

  • Coinbase Error – “Merchant tools have been restricted for your account”

    No comments August 14th, 2017 46

    Bitcoin Gateway Error - Response: Merchant tools have been restricted for your account.

    This error indicates that Coinbase has disabled your Merchant account / Merchant tools or has not yet approved the Merchant account. You will need to contact their support department to find out more information as to why this has happened and what can be done (if anything) to resolve the issue.

    Please note that this error has nothing to do with our module and we have no influence over Coinbase’s decision to disable or enable your Merchant account.

    1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
    Loading...
  • Coinbase error – “invalid signature”

    No comments April 13th, 2017 202

    Coinbase Gateway Error - Response: invalid signature

    This error means that the API keys in the WHMCS gateway settings for the Coinbase module are not valid or are not generated for Coinbase’s updated API (v2). Please regenerate the keys making sure that you create the HMAC keys for API v2 and you select the correct permissions as shown in the article linked below.

    Coinbase API Requirements

    1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
    Loading...
  • Coinbase error – “You have not filled out your merchant profile. Please enter your information in the Profile section”

    No comments March 23rd, 2017 239

    Coinbase Gateway Error - Response: You have not filled out your merchant profile. Please enter your information in the Profile section.

    This error has 2 known causes…

    1. You have not filled out our completed your Coinbase Merchant profile, Login and complete your Merchant profile
    2. Coinbase has not yet approved your Merchant account

    If you have completed step #1, then you will need to wait for Coinbase to approve your Merchant account, we recommend that you contact Coinbase support to get more information regarding your account.

    1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
    Loading...
  • Coinbase error – “request timestamp expired”

    No comments March 23rd, 2017 243

    Coinbase Gateway Error - Response: request timestamp expired

    This error means that your server’s time is incorrect. Please contact your hosting provider or server administrator to correctly set the server’s time.

    1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
    Loading...
  • What is the “Callback Secret” option used for? Where do I find the value for this?

    No comments December 16th, 2014 1587

    As of v2.0.0 of the Coinbase module, the Callback Secret is no longer required and has been removed.

    The “Callback Secret” parameter is used to prevent bogus or fake callbacks to your payment gateway callback handler. The parameter should not be given to anyone as this is a “secret”. The value of this parameter can be anything you want, any alpha-numeric characters you’d like of any length (though we recommend 12 – 24 characters or so).

    We’ve even generated one for you (unique to your browser request). You can copy / paste this into the Callback Secret parameter field.

    K3sVucHx0tmfKh7Gzob6

     

    1 Star2 Stars3 Stars4 Stars5 Stars (2 votes, average: 5.00 out of 5)
    Loading...
  • “Error creating the Bitcoin payment button” – Common issues and solutions

    No comments October 23rd, 2014 1560

    The primary cause of the error is that your Coinbase Merchant profile has not been setup or completed. Please update and complete your Merchant profile here https://www.coinbase.com/merchant_profiles

    To get the error being generated by the Coinbase gateway, please view the WHMCS Activity Log. The activity log can be found under Utilities => Logs => Activity Log. When contacting our support team, please have a copy or a screenshot of the error so we may assist you faster.

    1 Star2 Stars3 Stars4 Stars5 Stars (1 votes, average: 5.00 out of 5)
    Loading...
  • What currencies are supported with the Coinbase Payment Gateway module?

    No comments April 7th, 2014 1596

    All currencies are supported. Both to and from XBT. However WHMCS is limited to the currencies that it supports.

    1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
    Loading...
  • Coinbase Payment Gateway Module changelog & release details

    No comments April 7th, 2014 2015

    Version 2.0.7 – Released 05.22.2017

    1
    
    Resolved an autoloader issue with WHMCS 7.2.x where the wrong *guzzle* component would be loaded

    Continue reading “Coinbase Payment Gateway Module changelog & release details” »

    1 Star2 Stars3 Stars4 Stars5 Stars (2 votes, average: 5.00 out of 5)
    Loading...
  • What are the API requirements for the Coinbase Payment Gateway module?

    2 comments April 6th, 2014 1760

    The following API settings are required to be able to accept Bitcoin payments from your WHMCS installation…

    1. Type: HMAC (Key + Secret)
    2. API v2
    3. Permissions…
      1. wallet:accounts:read
      2. wallet:checkouts:create
      3. wallet:checkouts:read
      4. wallet:orders:create
      5. wallet:orders:read
      6. wallet:orders:refund
      7. wallet:transactions:read
      8. wallet:transactions:request
      9. wallet:user:read
    4. Make sure to enable API access to the Wallet which you’d like to receive / refund payments from

    We do not recommend enabling any other permissions unless absolutely required. These permissions are required for our Coinbase Payment Gateway module to operate properly.

    1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
    Loading...
  • What are the requirements for the Coinbase Payment Gateway module?

    No comments April 6th, 2014 1624

    The requirements are listed below. The module may work under different conditions, but has only been tested by our developers in these scenarios.

    System Requirements

    • Working knowledge of WHMCS, installing and configuring addons, gateways etc.
    • PHP 5.6 or higher
    • WHMCS 7.x
    • OpenSSL w/ TLS 1.1+ support

    PHP Extension Requirements

    • cURL w/ TLS 1.1+ support
    • DOM
    • Hash
    • Ioncube Loader v6.0.2 or higher
    • JSON
    • OpenSSL
    • SimpleXML
    • XMLWriter

    Coinbase Requirements

    • A Coinbase account - If you do not have one, you may sign up here
    • Completed your Coinbase Merchant profile - https://www.coinbase.com/merchant_profiles
    • An active Coinbase Merchant account
    • v2 API Account (as of v2.0.0, API v1 is no longer supported)

    Requirements Test Script

    We offer a PHP script that will quickly and easily check your PHP and WHMCS installation for any missing requirements, the tool can be downloaded here - https://billing.aspnix.com/dl.php?type=d&id=138

     

    1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
    Loading...

CLOSE
CLOSE